Voice Internetworking Experts


Post New Topic  Post A Reply
my profile | register | search | faq | forum home
  next oldest topic   next newest topic
» Voice Internetworking Experts   » Cisco CCIE Voice Discussion Forums   » CCIE Voice Lab   » MGCP Gateway registration problem

UBBFriend: Email this page to someone!    
Author Topic: MGCP Gateway registration problem
ce_j1
Guru

Member # 26889

Member Rated:
posted March 19, 2009 07:29 AM      Profile for ce_j1     Send New Private Message      Edit/Delete Post  Reply With Quote 
Hello everybody,

i hav two problems:

1. my MGCP Gateway is not registrering with the call agent(Sub), but does that with the redundant host (Pub). What should I be watching out for here?

2. THe second problem is that whenever I reboot the router, I will have to issue a 'no isdn bind-l3 ccm and isdn bind-l3 ccm' on the serial interface to get a MULTIPLE FRAME ESTABLISHED on L2. I dont think the proctor, would do thAT FOR ME IN THE LAB THAT MEANS i WILL LOOSE POINTS. Any thoughts on these? Thanks. Here are some output from my router:

BR1_Rtr#sh run
Building configuration...

Current configuration : 2400 bytes
!
! Last configuration change at 08:32:13 utc Thu Mar 19 2009
! NVRAM config last updated at 05:09:03 utc Thu Mar 19 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR1_Rtr
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
clock timezone utc -5
tdm clock E1 0/0 both export line
voice-card 0
!
ip cef
!
!
!
!
multilink bundle-name authenticated
isdn switch-type primary-net5
!
!

username admin password 0 CJ!ciscoa11
archive
log config
hidekeys
!
!
controller E1 0/0
pri-group timeslots 1-3,16 service mgcp
!
!
!
!
!
interface Loopback0
ip address 192.168.2.2 255.255.255.255
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
speed auto
!
interface FastEthernet0/0.20
description BR1-Data-Vlan
encapsulation dot1Q 20
ip address 10.20.0.1 255.255.255.0
!
interface FastEthernet0/0.120
description BR1-Voice-Vlan
encapsulation dot1Q 120
ip address 10.120.0.1 255.255.255.0
ip helper-address 192.168.40.100
!
interface Serial0/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn outgoing display-ie
no cdp enable
!
interface Serial1/0
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ip address 10.10.33.2 255.255.255.128
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 101
!
router ospf 1
log-adjacency-changes
network 10.10.33.0 0.0.0.127 area 0
network 10.20.0.0 0.0.0.255 area 0
network 10.120.0.0 0.0.0.255 area 0
network 192.168.2.2 0.0.0.0 area 0
network 192.168.19.0 0.0.0.255 area 0
network 192.168.99.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
!
voice-port 0/0:15
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 192.168.40.100
ccm-manager mgcp
no ccm-manager fax protocol cisco
!
mgcp
mgcp call-agent 192.168.40.110 service-type mgcp version 0.1
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login local
!
ntp clock-period 17208149
ntp server 192.168.3.3
end

BR1_Rtr#sh ccm
BR1_Rtr#sh ccm-manager
MGCP Domain Name: BR1_Rtr
Priority Status Host
============================================================
Primary Down 192.168.40.110
First Backup Registered 192.168.40.100
Second Backup None

Current active Call Manager: 192.168.40.100
Backhaul/Redundant link port: 2428
Failover Interval: 30 seconds
Keepalive Interval: 15 seconds
Last keepalive sent: 10:11:09 utc Mar 19 2009 (elapsed time: 00:00:03
)
Last MGCP traffic time: 10:11:09 utc Mar 19 2009 (elapsed time: 00:00:03
)
Last failover time: 08:32:07 utc Mar 19 2009 from (192.168.40.110)
Last switchback time: 08:27:51 utc Mar 19 2009 from (192.168.40.100)
Switchback mode: Graceful
MGCP Fallback mode: Enabled/OFF
Last MGCP Fallback start time: 08:28:07 utc Mar 19 2009
Last MGCP Fallback end time: 08:32:24 utc Mar 19 2009
MGCP Download Tones: Disabled
TFTP retry count to shut Ports: 2

Backhaul Link info:
Link Protocol: TCP
Remote Port Number: 2428
Remote IP Address: 192.168.40.100
Current Link State: OPEN
Statistics:
Packets recvd: 6
Recv failures: 1
Packets xmitted: 5
Xmit failures: 0
PRI Ports being backhauled:
Slot 0, port 0
FAX mode: disable
Configuration Error History:

Posts: 207 | From: germany | Registered: Sep 2008  |  IP: Logged
Gonzalo
Member

Member # 18486

posted March 19, 2009 11:54 PM      Profile for Gonzalo        Edit/Delete Post  Reply With Quote 
Hi,
Just want to double check that in CUCM
status poll and B-channel maintenance are correctly configured.
Which IOS version
Can u reload and do a debug mgcp packet and debug ccm-managaer backhaul events/messages ?

Thanks

Posts: 15 | From: San Jose, CA | Registered: Mar 2006  |  IP: Logged
ce_j1
Guru

Member # 26889

Member Rated:
posted March 20, 2009 05:04 AM      Profile for ce_j1     Send New Private Message      Edit/Delete Post  Reply With Quote 
my IoS version is 12.4(15)T8 and yes the stas poll for the GW and the two analog ports on the GW's are set.
Posts: 207 | From: germany | Registered: Sep 2008  |  IP: Logged
ce_j1
Guru

Member # 26889

Member Rated:
posted March 20, 2009 09:15 AM      Profile for ce_j1     Send New Private Message      Edit/Delete Post  Reply With Quote 
THanks Gonzalo, figured it out. it now registering properly. I still have the problem though, that after a reboot, i have to issue the 'no isdn bind-l3 ccm and isdn bind-l3 ccm' to manually force the L2 to come up with MULTIPLE_FRAME ESTABLISHED
Posts: 207 | From: germany | Registered: Sep 2008  |  IP: Logged


All times are Eastern Time  
Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic next oldest topic   next newest topic
Printer-friendly view of this topic
Hop To:


Contact Us | Voice Internetworking Experts